Portal Android - Comunidade de Desenvolvedores Android
http://www.portalandroid.org/comunidade/

Erro Configuration 'compile' is obsolete
http://www.portalandroid.org/comunidade/viewtopic.php?f=2&t=31391
Página 1 de 1

Autor:  djandreroberto [ 28 Abr 2019, 16:35 ]
Assunto do Tópico:  Erro Configuration 'compile' is obsolete

Amigos boa tarde

estou editando um script de radio aqui só que ele me mostra a seguinte mensagem :

WARNING: Configuration 'compile' is obsolete and has been replaced with 'implementation' and 'api'.
It will be removed at the end of 2018. For more information see: http://d.android.com/r/tools/update-dep ... tions.html
Affected Modules: app

já alterei todos os compile e ele continua me mostrando essa mensagem abaixo o código que esta na página que mostra o erro:

apply plugin: 'com.android.application'

android {
compileSdkVersion 26
defaultConfig {
applicationId 'com.roxhospedagem.VidaPlena'
manifestPlaceholders = [onesignal_app_id : "",
// Project number pulled from dashboard, local value is ignored.
onesignal_google_project_number: "REMOTE"]
minSdkVersion 15
targetSdkVersion 26
versionName '1.0.0'
versionCode 1
}


buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
}
}
repositories {
jcenter()
mavenCentral() // GPUImage for Android
}
dexOptions {
javaMaxHeapSize "4g"
}
productFlavors {
}
}

dependencies {
implementation fileTree(include: ['*.jar'], dir: 'libs')
implementation files('libs/acra-4.5.0.jar')
implementation files('libs/ormlite-android-4.43.jar')
implementation files('libs/ormlite-core-4.43.jar')
implementation 'com.android.support:support-v4:26.0.0-alpha1'
implementation 'com.android.support:appcompat-v7:26.0.0-alpha1'
implementation 'com.android.support:design:26.0.0-alpha1'
implementation 'com.android.support:cardview-v7:26.0.0-alpha1'
implementation 'com.google.firebase:firebase-ads:10.0.0'
implementation 'com.google.firebase:firebase-messaging:10.0.0'
implementation 'com.loopj.android:android-async-http:1.4.9'
implementation 'com.github.bumptech.glide:glide:3.7.0'
implementation 'jp.wasabeef:glide-transformations:2.0.1'
implementation 'com.onesignal:OneSignal:3.10.8@aar'
implementation 'com.android.support.constraint:constraint-layout:1.0.2'
implementation 'com.android.volley:volley:1.0.0'

}
apply plugin: 'com.google.gms.google-services'


se alguém puder me ajudar agradeço

Página 1 de 1 Todos os Horários estão como UTC - 2 horas [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/