Portal Android - Comunidade de Desenvolvedores Android
http://www.portalandroid.org/comunidade/

ERROR: Failed to resolve: com.android.support:support-v7:28.
http://www.portalandroid.org/comunidade/viewtopic.php?f=2&t=31415
Página 1 de 1

Autor:  Allan Santos [ 10 Jun 2019, 14:26 ]
Assunto do Tópico:  ERROR: Failed to resolve: com.android.support:support-v7:28.

Ao USAR "implementation 'com.android.support:appcompat-v7:28.0.0-alpha1'" OCORRE O ERRO ABAIXO. QUAL DEVO USAR?

All com.android.support libraries must use the exact same version specification (mixing versions can lead to runtime crashes). Found versions 28.0.0, 25.1.0, 24.0.0. Examples include com.android.support:animated-vector-drawable:28.0.0 and com.android.support:support-media-compat:25.1.0 more... (Ctrl+F1).

Segue o restante do meu gradle:

apply plugin: 'com.android.application'
apply plugin: 'io.fabric'
//apply plugin: 'me.tatarka.retrolambda'


android {
compileSdkVersion 28
defaultConfig {
applicationId "paineiras.com.br.meupaineiras"
minSdkVersion 20
targetSdkVersion 28
versionCode 4
versionName "1.4"
multiDexEnabled true
testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
}
buildTypes {
release {
minifyEnabled false
proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
}
}
compileOptions {
sourceCompatibility JavaVersion.VERSION_1_8
targetCompatibility JavaVersion.VERSION_1_8
}

dexOptions {
javaMaxHeapSize "2048M"
}
lintOptions {

checkReleaseBuilds false

}
buildToolsVersion = '28.0.3'

}

dependencies {
implementation fileTree(include: ['*.jar'], dir: 'libs')
androidTestImplementation('com.android.support.test.espresso:espresso-core:2.2.2', {
exclude group: 'com.android.support', module: 'support-annotations'
})
implementation('cn.trinea.android.view.autoscrollviewpager:android-auto-scroll-view-pager:1.1.2') {
exclude module: 'support-v4'
}
implementation 'com.squareup.picasso:picasso:2.5.2'
implementation 'fr.avianey.com.viewpagerindicator:library:2.4.1.1@aar'
implementation 'com.squareup.okhttp3:okhttp:3.3.1'
implementation 'com.squareup.retrofit:retrofit:1.9.0'
implementation 'com.squareup.okhttp:okhttp:2.4.0'
implementation 'com.squareup.okhttp:logging-interceptor:2.6.0'
implementation 'com.roughike:bottom-bar:2.1.1'
implementation 'com.android.support:multidex:1.0.1'
implementation 'com.squareup.okhttp:okhttp-urlconnection:2.2.0'
//implementation 'com.android.support:appcompat-v7:jar:28.0.0-alpha1'
implementation 'com.android.support:appcompat-v7:28.0.0-alpha1' // ocorre o erro nesta linha, qua devo usar?

implementation 'com.android.support.constraint:constraint-layout:1.0.2'
implementation 'com.android.support:support-v7:28.0.0'
implementation 'com.android.support:design:28.0.0'
implementation 'com.makeramen:roundedimageview:2.1.1'
implementation 'q.rorbin:badgeview:1.1.3'
implementation 'com.journeyapps:zxing-android-embedded:3.5.0'
implementation 'me.leolin:ShortcutBadger:1.1.19@aar'
implementation 'com.google.firebase:firebase-messaging:10.2.1'
implementation 'com.google.android.gms:play-services:10.2.1'
implementation 'com.mikhaellopez:circularprogressbar:1.1.1'
implementation 'com.multidots:fingerprint-auth:1.0.1'
implementation 'com.crashlytics.sdk.android:crashlytics:2.9.1'
implementation 'android.arch.lifecycle:extensions:1.1.0'
implementation 'android.arch.lifecycle:viewmodel:1.1.0'
implementation 'android.arch.lifecycle:reactivestreams:1.1.0'
implementation 'com.squareup.retrofit2:retrofit:2.4.0'
implementation 'com.squareup.retrofit2:converter-gson:2.1.0'

implementation 'com.android.support:recyclerview-v7:28.0.0'
implementation "com.daimajia.swipelayout:library:1.2.0@aar"
implementation 'com.daimajia.androidanimations:library:1.1.2@aar'
implementation 'com.nineoldandroids:library:2.4.0'
implementation 'com.android.support:support-compat:28.0.0'

implementation 'com.vipulasri:ticketview:1.0.3'


implementation 'com.github.florent37:singledateandtimepicker:2.1.1'

implementation('com.shagi:material-datepicker:1.3') {
exclude group: 'com.android.support'
}
testImplementation 'junit:junit:4.12'
}

apply plugin: 'com.google.gms.google-services'
apply plugin: 'realm-android'

Página 1 de 1 Todos os Horários estão como UTC - 2 horas [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/