Portal Android - Comunidade de Desenvolvedores Android
http://www.portalandroid.org/comunidade/

AVD não inicia no Linux Mint - Android Studio
http://www.portalandroid.org/comunidade/viewtopic.php?f=6&t=30422
Página 1 de 1

Autor:  windxlum [ 05 Ago 2016, 02:44 ]
Assunto do Tópico:  AVD não inicia no Linux Mint - Android Studio

Boa noite galera!

Por favor, preciso muito de uma ajuda! Sou iniciante no assunto e estou estudando a linguagem android. Porém, estou com um problema na AVD, quando tento testar algum código desenvolvido.

Ela simplesmente não inicia no Linux. O emulador abre na tela e fica na tela com o nome android e não carrega nunca. Observando alguns logs, identifiquei algumas mensagens de erro:

Aba Run:
/home/windxlum/Android/Sdk/tools/emulator -netdelay none -netspeed full -avd Nexus_7_2012_API_19
emulator: WARNING: VM heap size set below hardware specified minimum of 96MB
emulator: WARNING: Setting VM heap size to 256MB
console on port 5554, ADB on port 5555
emulator: ERROR: _factory_client_recv: Invalid format in query 'list�xE�pH�Ӆ�Tb��ף��H��H���xE�pH�Ӆ�Tb������H��H���xE�pH�Ӆ�Tb�H��H���8N�p��ib���$�'
emulator: ERROR: _factory_client_recv: Unknown camera factory query name in ''


Aba Android Monitor:

08-04 23:36:35.673 2677-2677/? E/System: ******************************************
08-04 23:36:35.673 2677-2677/? E/System: ************ Failure starting system services
java.lang.RuntimeException: There must be one required installer
at com.android.server.pm.PackageManagerService.getRequiredInstallerLPr(PackageManagerService.java:2421)
at com.android.server.pm.PackageManagerService.<init>(PackageManagerService.java:2327)
at com.android.server.pm.PackageManagerService.main(PackageManagerService.java:1764)
at com.android.server.SystemServer.startBootstrapServices(SystemServer.java:366)
at com.android.server.SystemServer.run(SystemServer.java:268)
at com.android.server.SystemServer.main(SystemServer.java:168)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:726)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)
08-04 23:36:35.673 2677-2677/? D/AndroidRuntime: Shutting down VM
08-04 23:36:35.673 2677-2677/? E/AndroidRuntime: *** FATAL EXCEPTION IN SYSTEM PROCESS: main
java.lang.RuntimeException: There must be one required installer
at com.android.server.pm.PackageManagerService.getRequiredInstallerLPr(PackageManagerService.java:2421)
at com.android.server.pm.PackageManagerService.<init>(PackageManagerService.java:2327)
at com.android.server.pm.PackageManagerService.main(PackageManagerService.java:1764)
at com.android.server.SystemServer.startBootstrapServices(SystemServer.java:366)
at com.android.server.SystemServer.run(SystemServer.java:268)
at com.android.server.SystemServer.main(SystemServer.java:168)
at java.lang.reflect.Method.invoke(Native Method)
at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:726)
at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:616)

08-04 23:36:35.674 2677-2677/? E/AndroidRuntime: Error reporting crash
java.lang.NullPointerException: Attempt to invoke interface method 'void android.app.IActivityManager.handleApplicationCrash(android.os.IBinder, android.app.ApplicationErrorReport$CrashInfo)' on a null object reference
at com.android.internal.os.RuntimeInit$UncaughtHandler.uncaughtException(RuntimeInit.java:90)
at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:693)
at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:690)


Alguém já teve este erro? Poderiam me ajudar?

Obrigado!

Página 1 de 1 Todos os Horários estão como UTC - 2 horas [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/